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MassHunter Quantitative Analysis Software
Review and Quant Method Optimization

Topics 

• Batch Definitions

• Three main views in MassHunter Quantitative Analysis

• Developing a quantitation method

Method Editor tasks

• Analyze the batch

• Outlier setup

• Advanced Tasks 

Integration parameters

• Data review 

• Generating a report, modifying graphic output
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Definitions

Batch - A set of data files that may include calibrators, samples, blanks, 

and QC samples.  The data in the batch will be operated on by one 

method.  The method and calculated results are contained in the batch.  

Quant Method – A list of target compounds with quantifier and qualifier 

ions specified for each compound, retention times, ISTD info, calibrator 

concentrations, outliers, integration parameters, and much more.  

Results – After the batch has been analyzed, results are generated and 

contained within the batch (xml file).  These results are displayed in a 

tabular format in the Batch Table and graphically in either the Batch 

View or the Compounds at a Glance View.  

Batch Contents

Acquired Data     Quant Method Results
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Definitions

SQ – Single quadrupole instrument low or unit mass resolution data.  

Can be scan data or SIM.

QQQ – Triple quadrupole or tandem quadrupole.  Composed of a Q1, 

collision cell (Q2) and Q3.  Usually acquired in multiple reaction monitor 

(MRM).  MS/MS data.

TOF – Time of flight High resolution mode.  Gives exact mass to 4 

decimal places.  Data acquired in scan mode.

Q TOF – Quadrupole combined with high resolution TOF.  MS/MS data.
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MassHunter Quantitative Software

There are 15 possible Quantitative Analysis icons 
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Use the icon applicable to 

the instrument and dataset 

for the application.

2D UV signals (UV only)can 

be processed with the GC 

icon or as part of an MS 

method.

Same core software different 

UI.



Typical Data Folder Structure
Four Basic Components to the Batch Directory
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Use the icon applicable to the instrument and dataset 

for the application.

Calibrators, samples, 

blanks, QC and CC 

samples comprising the 

batch.

Quant Method

Batch.bin file



MassHunter Quantitative Software
Batch-at-a-Glance View
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Batch Table

Calibration CurveCompound Information



Method 
Tasks

MassHunter Quantitative Software
Method Editor View

Method > Edit menu or F10 key
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Method Table

Sample 

Information

Compound Information



MassHunter Quantitative Software
Compounds at a Glance

View > Compounds-at-a-Glance
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Important MassHunter Quant Concepts and Rules
Batch Setup

A Batch is a file which contains all the Quant results from a set of data files 

and the Quant method used. 

All the data files in a Batch must reside in a single directory, so put them all 

together before creating a New Batch.

Create the Batch name within the batch directory.

Using the single batch concept allows for easy archiving and retrieving of 

data.

All information about the batch is stored in the QuantResults\batch.bin file

1/10/2018

MassHunter Webinar Series

10



Important MassHunter Quant Concepts and Rules:
Quant Methods

The most common method problem: Calibration/QC level names in Batch 

and Quant method do not match, e.g.

- Method: levels are 1,2,3,4,5

- Batch: levels are L1,L2,L3,L4,L5

Second most common problem: a hidden column in the Method with a key 

parameter, e.g. Ion Polarity if method created manually.

Many Quant parameters can be applied to multiple compounds with the Fill 

Down feature or Apply to All button.
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Creating a Batch for Processing

Batch-at-a-Glance

1) File > New Batch…

2) Create the batch in the directory in which the data files reside

3) Add Samples

4) 

5) Method > Open Method from Existing File…

Or Method > Open Method from Existing Batch…
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Let’s take a moment 
for questions on batch 
definitions and setting 
up a batch. 

Up Next:

Setting up a quantitation 

method.
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Short Demo



Creating a Quantitation Method for SQ
Method > New
New Method from Acquired SIM Data…

Only available from MS Quantitative Analysis icon.
Available in QQQ but not as useful.

New Method from Acquired Scan Data…
(with Library Search)

Use Library Method to identify and create compounds.
Clean up unwanted compounds.
Edit ions choices (Selected ions may not be the “best” ions).

New Method from Acquired Chromatographic Data…
Used for 2D Data (UV, FID, ECD, etc.).
Gives only Compound_1, etc. based on RT.

New Method using Manual Setup
Manually enter compound data (RT, concentration, masses, etc.).
Can be tedious for large number of compounds.

New Method from File…
From CEF file generated in Qualitative Analysis.
From a small user generated library.
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Editing a Quantitation Method  

Step through Method Setup Tasks
Applies to SQ, TOF, QTOF.

In QQQ MRM Setup
Allows setup of transitions with precursor
and product ions.
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Method Editor
-Method Tasks 

Method Tasks organizes the method 

actions  and parameters into related 

sections.

Use when you cannot 

add compounds or 

qualifiers 

automatically.

Main method 

editing functions.

Validate content,

save and apply

Quant method.
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Editing a Quantitation Method for SQ
Compound Setup

Name – compound name
TS – time segment usually 1 for scan data

may be many time segments for SIM and MRM data
Type – Target, ISTD, Surrogate or Matrix Spike
MZ – mass of target or quantifier ion
RT – retention time of compound of interest
Ion Polarity – may be Positive, Negative, Unassigned or Both

- in most applications, it will be positive 
Criteria – Close RT, Close RT with Qualifiers, Greatest Response or 

Greatest Q- value
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Editing a Quantitation Method for All Instruments
Retention Time Setup

RT – retention time of compound of interest
Left RT Delta – represents the left side of the EIC window around the     

expected retention time.
Right RT Delta - represents the right side of the EIC window around 

the expected retention time 
RT Delta Units – typically in minutes.
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Editing a Quantitation Method for All Instruments

ISTD Setup
Defines the ISTD and associates each ISTD with one or more target 

compounds.
Multiple ISTDs can be assigned in a method.

ISTD - Flag Toggle this flag on for all  ISTDs
Type - Compounds assigned as an ISTD become available 
ISTD - Compound Name Establishes concentration levels
ISTD Conc. – a concentration must assigned for each ISTD
Time Reference Flag – only ISTD can be assigned as time reference 

compounds
A Time Reference ISTD adjusts the RT of all target compounds 

related to a given ISTD due to slight RT shifting due to extraneous factors 
such as matrix effects. This is done a on a per sample basis. 
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Editing a Quantitation Method for All Instruments 
Concentration Setup
Defines the concentration of each compound in the standards.

Level in Method must match Level in 

Batch table!

If Unchecked a level 

can be disabled and not 

appear in the calibration 

curve.
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Editing a Quantitation Method for All Instruments
Concentration Setup
Calibration levels can be created manually or automatically.

Fill in levels 

and 

associated 

concentrations

.  

Manual Setup Setup Levels from Calibrators, QCs & CCs in Batch

Level IDs are filled 

in from the 

Calibrators, QCs & 

CCs in the batch.

Concentrations 

must be updated!   

Click to add 

calibration 

levels.
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Creating a Quantitation Method for All Instruments
Concentration Setup – Create Levels from Calibration Samples
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Then Method > Edit and then 

Method > Create Levels from 

Calibration Sample.



Editing a Quantitation Method for All Instruments 
Concentration Setup

If concentrations are the same, they can be copied to the other compounds.
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Editing a Quantitation Method for All Instruments
Qualifier Setup 

Right click 

Qualifier may be  

added interactively
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Editing a Quantitation Method for All Instruments
Qualifier Setup 

If checked, qualifier area 

is added to target.

Expected Qualifier Ion response as Percentage 

of Quant Ion, and Percentage Uncertainty.

80% Relative Response with 20% Uncertainty

Absolute = 80 +/- 20 = range of 60-100

Relative = 80 +/-(80*20/100) = range of 74 - 96
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Editing a Quantitation Method for All Instruments
Calibration Curve 

Curve Fit

•Linear.

•Quadratic.

•Power.

•1st order ln.

•2nd order ln.

•Average response factors.

Curve Fit Origin

•Ignore

•Include.

•Force.

•Blank offset.

Curve Fit Weight

•None (equal wt.)

•1/x, 1/x2

•1/y,1/y2

•Log

•1/SD2.

Note:  Calibration Curve not available for viewing until batch is analyzed.
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Editing a Quantitation Method for All Instruments
Globals Settings

Apply Multiplier’s 

To avoid flagging target compounds that absent

None or Overlapped or Sample Group

Peak identification within the extraction window

Associates target and qualifiers in min

Semi quant relative to ISTD

Quantitate with Standard Addition

Peak identification within the extraction window

(ISTD with Time Reference Flag checked)

Spectral Reference Library (.reflibrary.xml)

Dynamic Background Subtraction Video

Spectral Pattern Reference Library (.reflibrary.xml)

Part of unified method
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Quant/Method Editor - Dynamic Background Subtraction - Advanced.exe


Editing a Quantitation Method for All Instruments
Validate
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Red icon – Must be 

corrected

Yellow icon - Warning

Save and Save As – A quant method 

can be saved and applied to multiple 

batches.  



Editing a Quantitation Method for All Instruments
Exit Method Editor and Apply Method
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Analyze may (*) rebuild the 

calibration curve and then 

calculates analyte concentrations.

Quantitate does not rebuild the 

calibration curve but calculates 

concentrations based on the 

existing curve.

Integrate simply calculates the 

response for compounds in the 

batch.  It does not use the 

calibration curve nor obtain final 

concentrations.

* 



Analyzed Batch !!!
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Once developed, Methods can be used over and over.



Saving a Method with the Calibration Table Information

Method >Edit > Save As method to retain calibration table. 
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Editing a Quantitation Method for QQQ 
Compound Setup

Name – compound name
TS – time segment usually 1 for scan data

may be many time segments for SIM and MRM data
Transition – Precursor ion Product ion
Scan – MRM (Multiple Reaction Monitor) 
Type – Target, ISTD, Surrogate or Matrix Spike
Precursor ion – mass of the ion
Product Ion – mass of the ion
RT – retention time of compound of interest 
Ion Polarity – may be Positive, Negative, Unassigned or Both

- in most applications, it will be positive 
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Editing a Quantitation Method for QQQ
Qualifier Setup

Precursor Ion – mass of the ion
Product Ion – mass of the ion
Transition – Precursor ion Product ion 
Relative Response – ratio of Qualifier to Quantifier
Uncertainty – amount of variation of the relative response
Area Sum – summation of qualifier area to the target area.
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Editing a Quantitation Method for TOF
Mass Extraction Setup

Method > Edit > Advanced Tasks > Mass Extraction Setup

Allows for a mass range for the extraction of the accurate mass (MZ). 

Available MZ Extraction Window Units
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Editing a Quantitation Method for QTOF
Compound Setup & Mass Extraction Setup

QTOF is a combination of MS/MS and accurate mass data

Name – Compound name
TS – time segments may be multiple 
Transition – Precursor ion Product ion scan
Scan – Product Ion
Type – Target, ISTD, Surrogate or Matrix Spike
Precursor Ion – mass of the ion
Product Ion – mass of the ion for the target ion to monitor
RT – retention time of compound of interest 
Ion Polarity – usually positive
Criteria – Close RT, Close RT with Qualifiers, Greatest Response or 
Greatest Q-Value 
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Using an Existing Method
Method > Open from Existing File… 
Method > Open from Existing Batch…

The quantitation database is saved in the method and in the batch file and 

can be recalled from either location.

Opening and applying  method from existing file or batch does not 

automatically enter the Method Editor—stays at the Batch Table.
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Analyzed Batch !!!
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Once developed, Methods can be used over and over.



Let’s take a moment 
for questions on 
setting up a 
quantitation method 
and Method Editor.

Up Next:

Outlier Tasks

January 10, 2018
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Demo



Outlier Setup Tasks

Outliers are setup in the 

Method Editor and are part 

of quant method.

Outliers are used to 

perform automated quality 

checks.

Aids in data review by 

highlighting problem areas.

Increases confidence in 

data integrity by applying 

outliers.

Greater than 45 outliers 

are available. 

Can create Custom 

Calculations.
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Outliers in Batch At a Glance

Select Outliers

Turn off outlier filter

Display rows that have High/Low 

outliers

Display rows that have High outliers

Display rows that have Low outliers 

Display rows that have no outliers
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Icons on the toolbar



Outliers Help
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Outliers Videos
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Many Outliers have videos associated on the topic

Quant videos are located on the 

Desktop (if installed)

Quant B.08 DVD 2 of 3 in 

MassHunter > Videos > Quant



Editing a Quantitation Method
Advanced Tasks Integration Parameters
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Accessed via Method > Edit > Advanced Tasks > Integration 

Parameters Setup

Each compound can have a unique 

set of integration parameters.

Each qualifier can have unique 

parameters or same as target ion.

Integration parameters can be 

applied to ALL compounds.



Editing a Quantitation Method
Integrator Parameters
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Agile2

Default Integrator, 3rd generation parameter less integrator

Better baselines, higher sensitivity to smaller peaks.

Agile

2nd generation parameter less integrator.

MS/MS and MS/MS (GC)

1st generation parameter less integrator intended for MS/MS 

systems, not recommended for SQ. Originally required 64 data points.

All parameter less algorithms

have Peak Filter tab.



Editing a Quantitation Method
Integrator Parameters
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General (RTE)

Familiar to MSD ChemStation users.

Areas in Universal are 10 time smaller

than seen in ChemStation.

Universal

1st generation ChemStation 

integrator. 

Familiar to MSD ChemStation 

users.

Significant number of timed events.



Editing a Quantitation Method
Integrator Parameters
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Spectrum Summation

Integrator designed for situations where compounds are poorly separated or 

peak shape is highly irregular.

PCB mixtures, TPH and GRO

Fraction cut in hydrocarbons

Flow injection analysis

Sums signal over a time range

Exclude signal below threshold

Always gives a horizontal baseline

RT reported as the center of the time

range



Editing a Quantitation Method

Method > Edit then Tools > Actions > Set Peak Filter Area Threshold 

Choose any value as a percentage of lowest calibrator
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Setting an integration threshold



Compounds-at-a-Glance

1/10/2018

MassHunter Webinar Series

48

View > Compounds-at-a-Glance…



Compounds-at-a-Glance
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Manual integration – right-click context menu or

Indicates 

an outlier



Compounds-at-a-Glance

1/10/2018

MassHunter Webinar Series

50

Zero multiple peaks

Select manual integration icon 

Hold down CTRL key, click multiple peaks, click the zero peak icon.



Let’s take a moment 
for questions on 
Compounds at a 
Glance

Up Next:

Reporting
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Report Generation
Excel
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Quant Report 

Method

Report > Generate

Report folder 



Report Method Edit
Excel

Report Mode – Batch or Single Sample.

Publish Format – XLSX, PDF, TEXT or CSV.
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Excel template is 

XLTX file



Report Method Edit
Excel

Results tab
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Select the correct 

instrument type

For Excel  always select 

Auto or Yes



Report Method Edit
Excel

Graphic Settings tab.

Allows customization of the graphics output.
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Always generate 

the graphics if the 

file contains 

graphic output.



Report Method Edit
PDF Reporting

PDF Reports are located D:\MassHunter\Report Templates\Quant\PDF-

Reporting folder.

Run much faster for large batches.

PDF reports are built on Python code and take the form of xml files.

Only available Publish format is PDF.

On the Results tab, there is no need to generate the results file.

On the Graphic Settings tab, there is no need to Generate graphics files.
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Report Method Edit
PDF Reporting
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PDF Reporting will still generate graphics even when this checkbox is disabled.



Report Method 
Graphic Settings
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Applies to Excel or PDF 

Reporting.

Label compound name 

on the TIC.

For 2D data such as 

GC/FID, check “overlay 

signals” to display the 

sample chromatogram. 



Report Method 
Example
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TIC labeled with RT and Compound Name and Overlay Targets.



Report Method 
Graphic Settings
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Applies to Excel or PDF Reporting.

Normalize the qualifier ions.



Report Method 
Example

1/10/2018

MassHunter Webinar Series

61

Example of Target ion shaded green and qualifiers with uncertainty band.



PDF Report  Builder 
Allows user to generate unique report styles
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Allows user to customize report styles.



PDF Report  Builder 
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Relatively simple to learn and use.

Uses a GUI to layout report items.

Property based customization.

12 Quant templates are available.

Report Builder Familiarization guide.

A number of videos are available.



Training Resources
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Training resources that are available.
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Introducing Agilent University

Upgraded customer experience:
• Search and find courses that meet 

your interests and needs in the format 
they require.

Introduce new eLearning 
capabilities:

• Recorded and video-based learning 

• Virtual online classes 

Expanded portfolio:
• Foundational subjects

• Intermediate subjects

• Advanced subjects 

• Workflow and applications

Helping customers:
• Educate your employees on Agilent 

instruments and software

• From new hires to the most seasoned 
scientists



Questions on today’s material…
Thank you for your attention.

MassHunter Quantitative Analysis


